Sunday, 1 July 2012

Progress report



This week has been used to work on our topology 3 that has been covered more than other topologies, but later on each of these topology will be sufficiently covered to get convenient testing results so that the default behaviour can be  can be mastered, and modified to improve the performance of each routing protocol.
EIGRP, RIPv2 and OSPF with all devices in area 0 and next, with all devices in different area.








I.      OSPF

Case 1: OSPF (with only Area 0)
R1#show run

interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0

interface Serial0/0/0
 ip address 166.56.1.1 255.255.255.252
 clock rate 64000

interface Serial0/0/1
 no ip address
 no shutdown
 clock rate 125000


router ospf 1
network 166.56.1.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.255 area 0
R2#show run

interface Serial0/0/0
 ip address 166.56.1.2 255.255.255.252


interface Serial0/2/0
 ip address 172.16.3.1 255.255.255.252
 clock rate 64000


interface Serial0/2/1
 ip address 160.45.34.1 255.255.255.252


router ospf 1
network 160.45.34.0 0.0.0.3 area 0
network 166.56.1.0 0.0.3 area 0
R4#sh run

interface FastEthernet0/0
 ip address 170.16.30.1 255.255.255.0
 duplex auto
 speed auto

interface Serial0/0/0
 ip address 160.45.34.2 255.255.255.252
 no fair-queue
 clock rate 64000

interface Serial0/0/1
 ip address 172.16.2.1 255.255.255.252
 clock rate 64000

interface Serial0/2/1
 ip address 172.16.4.1 255.255.255.252


router ospf 1
network 160.45.34.0 0.0.0.3 area 0
network 172.16.2.0 0.0.0.3 area 0
network 172.16.4.0 0.0.0.3 area 0
network 170.16.30.0 0.0.0.255 area 0
R5#show run

interface Serial0/0/0
 no ip address
 shutdown
 no fair-queue
 clock rate 64000

interface Serial0/0/1
 ip address 172.16.4.2 255.255.255.252
 clock rate 64000

interface Serial0/2/0
 ip address 172.16.1.1 255.255.255.252


router ospf 1
network 172.16.1.0 0.0.0.3 area 0
network 172.16.4.0 0.0.0.3 area 0
R6#sh run

interface FastEthernet0/0
 no ip address
 no shutdown

interface Serial0/0/0
 ip address 172.16.1.2 255.255.255.252
 clock rate 64000

interface Serial0/0/1
 ip address 164.24.5.1 255.255.255.252

interface Serial0/2/1
 ip address 172.16.2.2 255.255.255.252


router ospf 1
network 164.24.5.0 0.0.0.3 area 0
network 172.16.1.0 0.0.0.3 area 0
network 172.16.2.0 0.0.0.3 area 0
R7#sh run

interface FastEthernet0/0
 ip address 172.30.1.1 255.255.255.0

interface Serial0/0/0
 ip address 164.24.5.2 255.255.255.252
  clock rate 64000


router ospf 1
network 164.24.5.0 0.0.0.3 area 0
network 172.30.1.0 0.0.0.255 area 0
ALS1#sh run

interface Port-channel1
 switchport mode trunk
 flowcontrol send off

interface FastEthernet0/1
 switchport mode trunk
 channel-group 1 mode desirable

interface FastEthernet0/2
 switchport mode trunk
 channel-group 1 mode desirable

interface FastEthernet0/3
 switchport access vlan 10
 switchport mode access

interface FastEthernet0/4
 switchport access vlan 20
 switchport mode access

interface Vlan55
 ip address 192.168.55.1 255.255.255.0

ALS2#sh run

interface Port-channel1
 switchport mode trunk
 flowcontrol send off

interface FastEthernet0/1
 switchport mode trunk
 channel-group 1 mode desirable

interface FastEthernet0/2
 switchport mode trunk
 channel-group 1 mode desirable

interface FastEthernet0/3
 switchport access vlan 20
 switchport mode access

interface FastEthernet0/4
 switchport access vlan 25
 switchport mode access

interface Vlan55
 ip address 172.30.55.1 255.255.255.0
ALS3#show run

Same as EIGRP
DLS2#show run

router ospf 1
network 10.0.0.0 0.0.0.255 area 0
network 172.30.1.0 0.0.0.255 area 0
network 172.30.10.0 0.0.0.255 area 0
network 172.30.15.0 0.0.0.255 area 0
network 172.30.20.0 0.0.0.255 area 0
network 172.30.25.0 0.0.0.255 area 0
network 172.30.55.0 0.0.0.255 area 0
DLS2#show run

router ospf 1
network 10.0.0.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
network 192.168.15.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
network 192.168.25.0 0.0.0.255 area 0
network 192.168.55.0 0.0.0.255 area 0
DLS3#show run


router ospf 1
network 170.16.30.0 0.0.0.255 area 0
network 170.16.20.0 0.0.0.255 area 0
network 170.16.10.0 0.0.0.255 area 0
network 170.16.15.0 0.0.0.255 area 0
network 170.16.25.0 0.0.0.255 area 0
network 170.16.55.0 0.0.0.255 area 0


Testing Scenarios:

In the following steps, simple testing tools have been used to check the path taken by a packet and see which manipulation is the most beneficial for the routing protocol:

* CLI with "traceroute "command  and "ping .... repeat" command
* Wireshark

More advanced tools will be used later to generate specific packets.

a. Using Default behaviour

* DLS2#traceroute 192.168.10.10 (Host connected to ALS1)

Type escape sequence to abort.
Tracing the route to 192.168.10.10

  1 10.0.0.1 0 msec 0 msec 8 msec
  2 192.168.10.10 0 msec 0 msec 9 msec


* DLS2#traceroute 192.168.10.10

Type escape sequence to abort.
Tracing the route to 192.168.10.10

  1 172.30.1.1 0 msec 0 msec 0 msec
  2 164.24.5.1 17 msec 17 msec 16 msec
  3 172.16.2.1 26 msec 33 msec 25 msec
  4 160.45.34.1 42 msec 42 msec 42 msec
  5 166.56.1.1 50 msec 59 msec 50 msec
  6 192.168.1.2 59 msec 51 msec 58 msec
  7 192.168.10.10 59 msec 50 msec 51 msec
DLS2#

From the above output, we notice that the preferred path for a packet forwarded from Host connected to ALS2 to Host connected to ALS1 is through ether channel link:


DLS2#ping 192.168.10.10 repeat 2000

Type escape sequence to abort.
Sending 2000, 100-byte ICMP Echos to 192.168.10.10, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
<output ommited>
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (2000/2000), round-trip min/avg/max = 1/2/9 ms





DLS2#ping 192.168.10.10 repeat 2000 (Port Channel disabled)

Type escape sequence to abort.
Sending 2000, 100-byte ICMP Echos to 192.168.10.10, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
<Output Ommited>
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.
*Mar  1 02:50:46.961: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern
et0/4, changed state to down
*Mar  1 02:50:47.003: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern
et0/3, changed state to down
*Mar  1 02:50:47.011: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-chann
el2, changed state to down
*Mar  1 02:50:47.959: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state t
o down
*Mar  1 02:50:48.009: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state t
o down
*Mar  1 02:50:48.009: %LINK-3-UPDOWN: Interface Port-channel2, changed state to
down
*Mar  1 02:50:48.009: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.55.250 on Port-chan
nel2 from FULL to DOWN, Neighbor Down: Interface down or detached...!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
<Output Ommited>
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 99 percent (1996/2000), round-trip min/avg/max = 1/44/143 ms
DLS2#



DLS2#ping 192.168.10.10 repeat 500

Type escape sequence to abort.
Sending 500, 100-byte ICMP Echos to 192.168.10.10, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!
Success rate is 100 percent (500/500), round-trip min/avg/max = 109/112/135 ms




DLS2#ping 192.168.10.10 repeat 500 (R6 S0/2/1 disabled)

Type escape sequence to abort.
Sending 500, 100-byte ICMP Echos to 192.168.10.10, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!..U.U.!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!
Success rate is 98 percent (494/500), round-trip min/avg/max = 109/133/160 ms
DLS2#






Case 2: OSPF (with only Area 100, 200 and 300)
Note: This table will show only OSPF configuration, the rest of configurations are the same as Case 1
R1#show run

router ospf 1
 log-adjacency-changes
 network 166.56.1.0 0.0.0.3 area 100
 network 192.168.1.0 0.0.0.255 area 100
R2#show run

router ospf 1
 log-adjacency-changes
 network 160.45.34.0 0.0.0.3 area 0
 network 166.56.1.0 0.0.0.3 area 100
R4#sh run

router ospf 1
 log-adjacency-changes
 network 160.45.34.0 0.0.0.3 area 0
 network 170.16.30.0 0.0.0.255 area 200
 network 172.16.2.0 0.0.0.3 area 0
 network 172.16.4.0 0.0.0.3 area 0
R5#show run

No change (Area 0 only)
R6#sh run

No change (Area 0 only)
R7#sh run

router ospf 1
 log-adjacency-changes
 network 164.24.5.0 0.0.0.3 area 0
 network 172.30.1.0 0.0.0.255 area 300
ALS1#sh run

No change
ALS2#sh run

No change
ALS3#show run

No change
DLS2 #show run

ip routing

interface Port-channel1
 switchport trunk encapsulation dot1q

interface Port-channel2
 no switchport
 ip address 10.0.0.2 255.255.255.0

interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 channel-group 1 mode desirable

interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 channel-group 1 mode desirable

interface FastEthernet0/3
 no switchport
no ip address
 channel-group 2 mode desirable

interface FastEthernet0/4
 no switchport
 no ip address
 channel-group 2 mode desirable

interface FastEthernet0/5
 no switchport
 ip address 172.30.1.2 255.255.255.0

interface Vlan10
 ip address 172.30.10.250 255.255.255.0

interface Vlan15
 ip address 172.30.15.250 255.255.255.0

interface Vlan20
 ip address 172.30.20.250 255.255.255.0

interface Vlan25
 ip address 172.30.25.250 255.255.255.0

interface Vlan55
 ip address 172.30.55.250 255.255.255.0


router ospf 1
network 10.0.0.0 0.0.0.255 area 300
network 172.30.1.0 0.0.0.255 area 300
network 172.30.10.0 0.0.0.255 area 300
network 172.30.15.0 0.0.0.255 area 300
network 172.30.20.0 0.0.0.255 area 300
network 172.30.25.0 0.0.0.255 area 300
network 172.30.55.0 0.0.0.255 area 300
DLS1#show run

ip routing

interface Port-channel1
 switchport trunk encapsulation dot1q

interface Port-channel2
 no switchport
 ip address 10.0.0.1 255.255.255.0

interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 channel-group 1 mode desirable

interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 channel-group 1 mode desirable

interface FastEthernet0/3
 no switchport
no ip address
 channel-group 2 mode desirable

interface FastEthernet0/4
 no switchport
 no ip address
 channel-group 2 mode desirable

interface FastEthernet0/5
 no switchport
 ip address 192.168.1.2 255.255.255.0

interface Vlan10
 ip address 192.168.10.250 255.255.255.0

interface Vlan15
 ip address 192.168.15.250 255.255.255.0

interface Vlan20
 ip address 192.168.20.250 255.255.255.0

interface Vlan25
 ip address 192.168.25.250 255.255.255.0

interface Vlan55
 ip address 192.168.55.250 255.255.255.0


router ospf 1
network 10.0.0.0 0.0.0.255 area 100
network 192.168.1.0 0.0.0.255 area 100
network 192.168.10.0 0.0.0.255 area 100
network 192.168.15.0 0.0.0.255 area 100
network 192.168.20.0 0.0.0.255 area 100
network 192.168.25.0 0.0.0.255 area 100
network 192.168.55.0 0.0.0.255 area 100
DLS3#show run

ip routing

interface Port-channel1

interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 channel-group 1 mode desirable

interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 channel-group 1 mode desirable

interface FastEthernet0/3

interface FastEthernet0/4

interface FastEthernet0/5
 no switchport
 ip address 170.16.30.2 255.255.255.0
interface Vlan1
 no ip address
 shutdown

interface Vlan10
 ip address 170.16.10.250 255.255.255.0

interface Vlan15
 ip address 170.16.15.250 255.255.255.0

interface Vlan20
 ip address 170.16.20.250 255.255.255.0

interface Vlan25
 ip address 170.16.25.250 255.255.255.0

interface Vlan55
 ip address 170.16.55.250 255.255.255.0


router ospf 1
network 170.16.30.0 0.0.0.255 area 200
network 170.16.20.0 0.0.0.255 area 200
network 170.16.10.0 0.0.0.255 area 200
network 170.16.15.0 0.0.0.255 area 200
network 170.16.25.0 0.0.0.255 area 200
network 170.16.55.0 0.0.0.255 area 200


Different test scenarios have been made, using default behaviour of the routing protocol, or modifying some of the characteristics (bandwidth, cost)
Most of the modification have been done on R6, R5 and R4 so that packets could be brought to choose a defined path and check which of the combination is the fastest.

But before applying any modification, the default interfaces status have been verified:

R6#sh int s0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 172.16.1.2/30
  MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  <Output omitted>
R6#
R6#sh int s0/2/1
Serial0/2/1 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 172.16.2.2/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
<output omitted>
 Available Bandwidth 1158 kilobits/sec





Testing Scenarios:

In the following steps, simple testing tools have been used to check the path taken by a packet and see which manipulation is the most benefique for the routing protocol.
Examples of tools used: Wireshark. CLI (ping ... repeat, traceroute, ip route)
More advanced tools will be used later to generate specific packets.

a. Using Default behaviour

* R6#sh ip route
                <Output omitted>
O       160.45.34.0 [110/128] via 172.16.2.1, 00:00:36, Serial0/2/1

Note: Cost = 128 to reach network 160.45.34.0 via 172.16.2.1

* R6#show ip route (R6 s0/2/1 shutdown)
                <Output omitted>
O       160.45.34.0 [110/909] via 172.16.1.1, 00:00:15, Serial0/0/0

Note: Cost = 909 to reach network 160.45.34.0 via 172.16.1.1

The first output in the next page (MSDOS) indicates that path taken by packet using default bandwidth link R4 - R6 (1544 kbps) and R5 - R6 (128 kbps), and R5 - R4 (1544 kbps) from Host 192.168.10.10 to host 172.30.20.20 is DLS1 - R1 - R2 - R4 - R6 - R7 - DLS2

* DSL2#ping 192.168.10.10 repeat 2000 (Default band:R4-R6 1544kbps;

Type escape sequence to abort.
Sending 2000, 100-byte ICMP Echos to 192.168.10.10, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
<Output omitted>
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (2000/2000), round-trip min/avg/max = 109/112/143 ms


* DSL2#ping 192.168.10.10 repeat 2000 (R4-R6 band 64; R6 s0/0/0 shut)

Type escape sequence to abort.
Sending 2000, 100-byte ICMP Echos to 192.168.10.10, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.U.U.!!!!!!!!!!!!!!!!
<output omitted>
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 99 percent (1995/2000), round-trip min/avg/max = 109/116/167 ms

b. Link R4 - R6 changed to 64 kbps

The second output  indicates that packet has changed path using DLS1 - R1 - R2 - R4 -  R5 -  R6 - R7 - DLS2, preferring a faster link.


DSL2#ping 192.168.10.10 repeat 2000 (link R4-R6 band changed to 64kbps)

Type escape sequence to abort.
Sending 2000, 100-byte ICMP Echos to 192.168.10.10, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
<Output omitted>
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (2000/2000), round-trip min/avg/max = 134/139/185 ms

c. Changing cost from 128 to 1000 for R6 S0/2/1

* R6#sh ip route
                <Output omitted>
O       160.45.34.0 [110/909] via 172.16.1.1, 00:00:51, Serial0/0/0

Note: when cost change from 128 to 1000 for R6 s0/2/1, new path is 172.16.1.1 with cost 909

Verification of configured cost :                 R6# sh ip ospf int s0/2/1
Process ID 1, Router ID 172.16.2.2, Network Type POINT_TO_POINT, Cost: 1000


* R6#sh ip route               (R6 s0/2/1 cost set to 1000; R6 s0/0/0 to 500 and R5 s0/0/1 to 500)
O       160.45.34.0 [110/1064] via 172.16.2.1, 00:00:09, Serial0/2/1
                    [110/1064] via 172.16.1.1, 00:00:09, Serial0/0/0

* DSL2#ping 192.168.10.10 repeat 2000 (R6 s0/2/1 cost changed to 1000)

Type escape sequence to abort.
Sending 2000, 100-byte ICMP Echos to 192.168.10.10, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
<Output ommited)
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (2000/2000), round-trip min/avg/max = 134/139/185 ms


* DSL2#ping 192.168.10.10 repeat 2000 (Link R5 - R6 cost = 500; R4- R5 Cost = 500)

Type escape sequence to abort.
Sending 2000, 100-byte ICMP Echos to 192.168.10.10, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
<Output omitted>
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (2000/2000), round-trip min/avg/max = 117/125/160 ms



Note that with the case of different area, the ether channel failed to forward packets. Is it the true behaviour or is it a result of misconfiguration? The question will be minded later.


d. Wireshark Statistics summary in brief

2000 pings with R6 - R5 shutdown; band = 64 kbps
2000 ping with R6 S0/2/1 Cost set to 1000
2000 ping with R6 S0/2/1 Cost = 1000; R5-R6 Cost = 500; R4-R5 Cost = 500
Time:
* First Packet: 2012-06-18 20:14:21
 *Last Packet: 2012-06-18 20:19:18
* Elapsed: 00:04:57


Traffic captured:
* Packets:                    3865
* Between first and last packet:                   297.022 sec
* Avg packets/sec: 13.013

Time:
* First Packet: 2012-06-18 21:26:50
 *Last Packet: 2012-06-18 21:31:56
* Elapsed: 00:05:05


Traffic captured:
* Packets:                    4249
* Between first and last packet:                   305.468 sec
* Avg packets/sec: 13.910
Time:
* First Packet: 2012-06-18 21:53:19
 *Last Packet: 2012-06-18 21:58:53
* Elapsed: 00:05:34


Traffic captured:
* Packets:                    4270
* Between first and last packet:                   334.080 sec
* Avg packets/sec: 12.781










II. EIGRP

EIGRP
Note: This table will show only EIGRP configuration, the rest of configurations are the same as OSPF
R1#show run

router eigrp 20
 network 166.56.1.0 0.0.0.3
 network 192.168.0.0
 network 192.168.0.0 0.0.255.255
 no auto-summary
R2#show run

router eigrp 20
 network 160.45.34.0 0.0.0.3
 network 166.56.1.0 0.0.0.3
 network 172.16.3.0 0.0.0.3
 no auto-summary
R4#sh run

router eigrp 20
 network 160.45.34.0 0.0.0.3
 network 170.16.30.0 0.0.0.255
 network 172.16.2.0 0.0.0.3
 network 172.16.4.0 0.0.0.3
 no auto-summary
R5#show run

router eigrp 20
 network 172.16.1.0 0.0.0.3
 network 172.16.4.0 0.0.0.3
 no auto-summary
R6#sh run

router eigrp 20
 network 164.24.5.0 0.0.0.3
 network 172.16.1.0 0.0.0.3
 network 172.16.2.0 0.0.0.3
 no auto-summary
R7#sh run

router eigrp 20
 network 164.24.0.0
 network 172.30.0.0
 no auto-summary
ALS1#sh run

Same as OSPF



ALS2#sh run

Same as OSPF


ALS3#show run

Same as OSPF

DSL2#sh run

router eigrp 20
 no auto-summary
 network 10.0.0.0 0.0.0.255
 network 172.30.0.0
DLS1#show run

 router eigrp 20
 no auto-summary
 network 10.0.0.0 0.0.0.255
 network 192.168.0.0 0.0.255.255
DSL3#show run

router eigrp 20
 network 170.16.10.0 0.0.0.255
 network 170.16.15.0 0.0.0.255
 network 170.16.20.0 0.0.0.255
 network 170.16.25.0 0.0.0.255
 network 170.16.30.0 0.0.0.255
 network 170.16.55.0 0.0.0.255


Testing Scenarios:

Two different testing tools have been used to test network convergence:
* CLI with "traceroute "command  and "ping .... repeat" command
* Wireshark

a.            A traceroute command from DLS2 to host connected to ALS1 (192.168.10.10) has shown that the preferred route for packets is through the ether channel media, the more faster link in our network.

* DSL2#traceroute 192.168.10.10  (Host connected to ALS1)

Type escape sequence to abort.
Tracing the route to 192.168.10.10

  1 10.0.0.1 0 msec 0 msec 9 msec
  2 192.168.10.10 0 msec 9 msec 0 msec

Because our network is redundant, the port channel disabled doesn't block our packet to get to destination. But which path will be used depend on the metric on router R6. The smallest metric will be preferred to a higher one as shown in the routing table on router R6.

* R6#sh ip route
                <Output omitted>
160.45.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       160.45.0.0/16 [90/2681856] via 172.16.2.1, 01:45:55, Serial0/2/1

The preferred path for the packet will be then through R7 - R6 - R4 - R2 - R1 - DLS1.
The following command confirm this preference

* DSL2#traceroute 192.168.10.10   (with port-channel disabled)

Type escape sequence to abort.
Tracing the route to 192.168.10.10

  1 172.30.1.1 0 msec 0 msec 0 msec
  2 164.24.5.1 17 msec 8 msec 8 msec
  3 172.16.2.1 34 msec 25 msec 25 msec
  4 160.45.34.1 42 msec 42 msec 42 msec
  5 166.56.1.1 50 msec 50 msec 59 msec
  6 192.168.1.2 50 msec 50 msec 59 msec
  7 192.168.10.10 51 msec 67 msec 51 msec


* DSL2#ping 192.168.10.10 repeat 10000

Type escape sequence to abort.
Sending 10000, 100-byte ICMP Echos to 192.168.10.10, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
<Output omitted>
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (10000/10000), round-trip min/avg/max = 1/2/9 ms
DSL2#





DSL2#ping 192.168.10.10 repeat 10000 (with port channel on DLS1 shut)

Type escape sequence to abort.
Sending 10000, 100-byte ICMP Echos to 192.168.10.10, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
<Output omitted>
!!!!!!!!!!!.
*Mar  1 08:50:39.740: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern
et0/3, changed state to down
*Mar  1 08:50:39.782: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern
et0/4, changed state to down
*Mar  1 08:50:39.791: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-chann
el2, changed state to down
*Mar  1 08:50:40.747: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state t
o down
*Mar  1 08:50:40.789: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state t
o down
*Mar  1 08:50:40.789: %LINK-3-UPDOWN: Interface Port-channel2, changed state to
down
*Mar  1 08:50:40.806: %DUAL-5-NBRCHANGE: EIGRP-IPv4:(20) 20: Neighbor 10.0.0.1 (
Port-channel2) is down: interface down.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!
<Output omitted>
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 99 percent (9998/10000), round-trip min/avg/max = 1/93/160 ms



Wireshark Statistics Summary in brief

10000 pings DLS2 to Host connected to ALS1
10000 pings DLS2 to Host connected to ALS1 (port-channel disabled)
Time:
* First Packet: 2012-06-16 21:54:10
 *Last Packet: 2012-06-16 21:54:48
* Elapsed: 00:00:38


Traffic captured:
* Packets:    20032
* Between first and last packet:  38.007 sec
* Avg packets/sec: 527.059

Time:
* First Packet: 2012-06-16 22:05:58
 * Last Packet: 2012-06-16 22:22:29
* Elapsed: 00:16:30


Traffic captured:
* Packets:   20910
* Between first and last packet:  990.154
* Avg packets/sec: 21.118

From these statistics, we can notice that the ether cannel  link is much more faster than the redundant link. It is able to process 527 packets per second when the redundant link need the same time to process only 21 packets.
Note that the redundant link here is R7 - R6 - R4 - R2 - R1 - DLS1

Compared to OSPF with the parameters  parameters used (default or modified), from the Wireshark statistics captured from these scenario, we can notice that EIGRP process in average much more packets per second. But this result is not enough to build a general conclusion.
More tests need to be done.



2 comments:

Convergence.com said...

It is good to have consistency in the number of pings sent, say 500 each time you run the test. This will be easier for comparisons and also to repeat say 10 times to enable us to come up with a true value or picture of the speed of convergence. Let's subject the topologies to the same tests in all respects.

Hervé said...

I am being controversial here, but you can expect the same type of comments during the presentation:
1- why is the topology so complicated? Can you justify the use of Ether-channel? Are they working at layer 3?
2- I thought that the project was about measuring the convergence of routing protocols why are workstations or layer 2 switches involved?
3 - Has anyone in the group started looking at results so far? Anything unusual?
4- what info about the convergence time are you getting out of Wireshark? I have the feeling that you are measuring the speed of the network instead of the convergence time

Feel free to contradict me on any point!

Do not loose track of the main aim of the project. If you are over complicating the topology, it will be much more difficult to interpret the results of your experiments. The experiments are just tools to help you to produce the report (final product) as described at the beginning of the semester.

Post a Comment